MediaWiki: Difference between revisions
→Troubleshooting: Database import issue |
|||
| Line 19: | Line 19: | ||
This likely means that you do not have Lua installed or it is not in the PATH. You will need to specify the Lua path in {{code|LocalSettings.php}} with this line: | This likely means that you do not have Lua installed or it is not in the PATH. You will need to specify the Lua path in {{code|LocalSettings.php}} with this line: | ||
{{highlight|lang= | {{highlight|lang=php|code= | ||
$wgScribuntoEngineConf['luastandalone']['luaPath'] = "/usr/bin/lua5.1"; | $wgScribuntoEngineConf['luastandalone']['luaPath'] = "/usr/bin/lua5.1"; | ||
}} | }} | ||
Revision as of 20:22, 1 September 2019
Docker
You can run MediaWiki from a Docker container. A proof of concept can be found at:
Data that would need to be imported to support customizations would include:
- Images / Uploads
- Extensions
- Skins
- The
LocalSettings.phpconfiguration file - Database (on a remote server / container / microservice), or a SQLite file on a volume
Troubleshooting
Scribunto Lua Failures
If templates cause this error:
Lua error: Internal error: The interpreter exited with status 127.
This likely means that you do not have Lua installed or it is not in the PATH. You will need to specify the Lua path in LocalSettings.php with this line:
$wgScribuntoEngineConf['luastandalone']['luaPath'] = "/usr/bin/lua5.1";
Database Import Incomplete
Database imports from MySQL 5.7.27 to a MariaDB 10.4.7 seems to fail. Imports only appear to complete if the database dump was made without Enclose export in a transaction enabled in PHPMyAdmin but subsequent edits on the destination wiki will result in this error message:
The revision #0 of the page named "some-article" does not exist.
This is usually caused by following an outdated history link to a page that has been deleted. Details can be found in the deletion log.
The source database doesn't seem to have any consistency issues. A table check and optimize was done without issue.