MediaWiki: Difference between revisions

From Leo's Notes
This page was last edited on 1 September 2019, at 21:12.
Line 31: Line 31:
}}
}}


On the source database server, I am unable to copy the database to another database with a different name. This suggests that the database on the source server is inconsistent and InnoDB isn't able to re-import the database.
If the export was made enclosed in a transaction, the import will render this error on the destination side:
{{highlight|lang=text|code=
[ERROR] Transaction not registered for MariaDB 2PC, but transaction is active
}}

Revision as of 21:12, 1 September 2019

Docker

You can run MediaWiki from a Docker container. A proof of concept can be found at:

Data that would need to be imported to support customizations would include:

  1. Images / Uploads
  2. Extensions
  3. Skins
  4. The LocalSettings.php configuration file
  5. Database (on a remote server / container / microservice), or a SQLite file on a volume

Troubleshooting

Scribunto Lua Failures

If templates cause this error:

Lua error: Internal error: The interpreter exited with status 127.

This likely means that you do not have Lua installed or it is not in the PATH. You will need to specify the Lua path in LocalSettings.php with this line:

$wgScribuntoEngineConf['luastandalone']['luaPath'] = "/usr/bin/lua5.1";

Database Import Incomplete

Database imports from MySQL 5.7.27 to a MariaDB 10.4.7 seems to fail. Imports only appear to complete if the database dump was made without Enclose export in a transaction enabled in PHPMyAdmin but subsequent edits on the destination wiki will result in this error message:

The revision #0 of the page named "some-article" does not exist.

This is usually caused by following an outdated history link to a page that has been deleted. Details can be found in the deletion log.

If the export was made enclosed in a transaction, the import will render this error on the destination side:

[ERROR] Transaction not registered for MariaDB 2PC, but transaction is active